The wls_install module requires:

  • Puppet version 4.0 or higher.
  • A valid License from Oracle to use this software.
  • A valid entitlement for usage.
  • Runs on most Linux systems.
  • Windows systems are NOT supported

To get a valid license for Oracle WebLogic, please contact your Oracle representative.