The zfs_appliance module requires:

  • Puppet version 4.0 or higher.
  • Access to an Oracle ZFS Storage Appliance
  • A valid entitlement for usage.
  • Runs on most Linux systems.
  • Windows systems are NOT supported